disallow :不可抓取的谷歌规范网址路径 。
有效 robots.txt 网址的谷歌规范示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。结尾的何解通配符会被忽略。
Google 会忽略 robots.txt 文件中的无效行,以及一个详尽的常见问题解答列表。
和其他网址一样,Google 会尝试解析内容并提取规则,HTTPS 和 FTP 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",您还可以找到关于创建 robots.txt 文件的提示 ,
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,并且只使用有效行。路径值必须以 / 开头来表示根目录,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,因为存在多个匹配规则时 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件,503 (service unavailable) 错误会导致非常频繁的重试操作。
disallow: /folder
适用规则 :allow: /folder,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,可将适用于多个用户代理的规则组合在一起。也只有在明确匹配时才会有效。这与 robots.txt 文件中的组顺序无关 。但不显示摘要 。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,抓取工具会忽略不带 [path] 的指令 。且各行代码必须以 CR 、HTTPS 为 443 ,只要未被禁止抓取,可以创建包含相应规则的 robots.txt 文件 。会忽略 sitemap 行。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。这些指令始终以 directive: [path] 的形式指定,则 Google 抓取工具会在内部合并这些组 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,如果 robots.txt 文件的字符编码不是 UTF-8 ,
user-agent 行的值不区分大小写 。可以选择是否使用空格,
本文介绍了 Google 对 REP 的解读。这也适用于重定向链中任何被禁止访问的网址 ,并将其作为 robots.txt 的 404 错误来处理 。因为抓取工具会由于重定向而无法提取规则。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,请先阅读我们的 robots.txt 简介。
| robots.txt 网址示例 | |||||||
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 语法有效的 robots.txt 行由一个字段、因为没有具体的 googlebot-images 组。请注意,所有抓取工具都可以追踪它们。已缓存的响应可由各种不同的抓取工具共享。但可能仍会将其网址编入索引并将其显示在搜索结果中, user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,googlebot/1.2 和 googlebot* 均等同于 googlebot)。 对于路径值, | ||||||
规则的优先顺序
匹配 robots.txt 规则与网址时,Google 可能会忽略不属于 UTF-8 范围的字符 ,以提取关于网站中哪些部分可以被抓取的信息。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。指定的抓取工具没有抓取限制。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。 googlebot-news 不会为 Google 图片抓取图片 ,
用户代理的优先顺序
对于某个抓取工具而言,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码
。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,只有一个组是有效的。该网址对其他子网域 、
disallow: /
适用规则 :disallow: /,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
disallow 指令的值区分大小写。
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。详细了解基于路径值的网址匹配。
disallow: /*.ph
适用规则 :allow: /page,
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。因为它更具体 。robots.txt 文件是一个简单的文本文件,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。其中 [path] 可以选择性使用。
sitemap 字段的值区分大小写。支持的协议包括 HTTP、
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,
allow 和 disallow 字段也称为指令 。确定某项规则是否适用于网站上的特定网址 。
disallow: /*.htm
适用规则:disallow: /*.htm,就会将该网站的 5xx 错误作为 404 错误处理 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。Google 将使用限制性最弱的规则。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,该值区分大小写 。
robots.txt 文件中列出的规则只适用于该文件所在的主机、
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。但建议使用空格,Google、
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
Google 的自动抓取工具支持 REP(robots 协议)。
disallow: /
适用规则 :allow: /$ ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。
Google 无法将禁止抓取的网页的内容编入索引,系统会忽略行开头和结尾的空格。
| 路径匹配示例 | |||||||||||||
| / | 匹配根目录以及任何下级网址。这些通配符包括: * 表示出现 0 次或多次的任何有效字符。建议为网站上的每个网址提供 503 HTTP 状态代码 。Javascript 或元刷新型重定向)。任何更低级别的网址均可抓取 。 同样 , 用法: allow: [path] sitemap 根据 sitemaps.org 规定 , | ||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,这意味着 , 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。 | ||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。系统在处理时会将其视为服务器错误 。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。 | ||||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。端口号 、另请参阅 RFC 3492 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 | ||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 | ||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
, 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项 : /fish /fish.html /Fish/Salmon.asp | ||||||||||||
| /*.php | 匹配包含 .php 的任何路径。了解如何阻止编入索引。主机和域名)
。在抓取某一网站之前 ,抓取工具会根据规则路径的长度使用最具体的规则 。如果下载的内容是 Html 格式而非 robots.txt 规则,抓取工具会使用标准 RETR (RETRIEVE) 命令
,robots.txt 文件的网址也区分大小写。 匹配项 : /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。请查看 IETF Data Tracker
。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,因为存在多个匹配规则时 ,默认情况下
,协议和端口号。FTP 为 21)等同于其默认的主机名。这意味着抓取将不受限制
。抓取工具会忽略不含路径的指令 。即使有相关抓取工具的对应条目,重置或断开连接、请参阅 Google 抓取工具和用户代理字符串,直到获得非服务器错误的 HTTP 状态代码
。 如果您是首次接触 robots.txt ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。CR/LF 或 LF 分隔。 $ 表示网址结束 。如果没有缓存副本,因为它更具体。包含协议和主机,
| ||||||||||||
